Case Log Stuck Loading in Transfer IQ

Incident Report for TeleTracking US

Resolved

Platform behavior related to the Case Log remaining in a “Loading…” state is stable and functionality has been restored. The incident is considered resolved.
Posted Apr 08, 2026 - 18:35 EDT

Monitoring

A fix has been applied and monitoring is in progress. We will continue to observe behavior to ensure Transfer IQ is functioning as expected.
Posted Apr 08, 2026 - 18:31 EDT

Update

We are investigating an issue where the Case Log remains in a “Loading…” state. This impacts Transfer IQ, and customers may be unable to view case activity as expected.
Posted Apr 08, 2026 - 18:19 EDT

Investigating

We are investigating an issue where the Case Log remains in a “Loading…” state. This impacts Transfer IQ, and customers may be unable to view case activity as expected.
Posted Apr 08, 2026 - 17:51 EDT
This incident affected: Products (Transfer IQ).