The subset of customers who reported issues with saving TCIQ cases is no longer experiencing issues.
Posted Nov 27, 2025 - 16:43 EST
Monitoring
Our internal resources have identified an issue with deployed code and have successfully rolled back the code to its previous state. We'll be monitoring to ensure that TCIQ cases are no longer experiencing errors when saving.
Posted Nov 27, 2025 - 16:13 EST
Update
Our internal resources are still investigating the reports of TCIQ cases not saving. This issue is currently intermittent and not always recreatable at this time.
Posted Nov 27, 2025 - 15:42 EST
Update
Our internal resources are still investigating the reports of TCIQ cases not saving. This issue is currently intermittent and not always recreatable at this time.
Posted Nov 27, 2025 - 15:13 EST
Update
We are continuing to investigate this issue.
Posted Nov 27, 2025 - 14:43 EST
Investigating
A subset of customers have reported issues saving cases in TCIQ. We're currently investigating this issue and will update here soon.