Potential Impact with Authentication Services

Incident Report for TeleTracking US

Resolved

The authentication services for Auth0 have been restored. The incident is considered resolved.
Posted Mar 05, 2026 - 10:48 EST

Monitoring

Our authentication vendor, Auth0, is reporting issues that may impact login authentication services with TeleTracking. At this time, no customer impact has been reported. We are monitoring this incident and will provide you with updates accordingly.
Posted Mar 05, 2026 - 10:04 EST
This incident affected: Auth0 (Auth0 User Authentication).