Our AWS cloud provider has completed recovery efforts, and all TeleTracking services should have now returned to normal operation.
Posted Oct 20, 2025 - 19:15 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 16:34 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 15:51 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 15:14 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 14:45 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 14:02 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 13:26 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may experience some intermittent latency until the underlying issue is completely resolved. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 13:23 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may be experiencing intermittent issues viewing dashboards in Data IQ. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 12:32 EDT
Update
Our AWS cloud provider continues to work toward full recovery. At this time, some TeleTracking customers may be experiencing intermittent issues viewing dashboards in Data IQ. We will continue to monitor the situation closely as we move closer to a complete resolution.
Posted Oct 20, 2025 - 11:59 EDT
Update
AWS support team continue to work towards full recovery of their services. At this time no TeleTracking customers are affected. We'll continue to monitor this outage from the AWS status page.
Posted Oct 20, 2025 - 10:49 EDT
Update
From the AWS Dashboard: We are making progress on resolving the issue with new EC2 instance launches in the US-EAST-1 Region and are now able to successfully launch new instances in some Availability Zones. We are applying similar mitigations to the remaining impacted Availability Zones to restore new instance launches. As we continue to make progress, customers will see an increasing number of successful new EC2 launches. We continue to recommend that customers launch new EC2 Instance launches that are not targeted to a specific Availability Zone (AZ) so that EC2 has flexibility in selecting the appropriate AZ.
Posted Oct 20, 2025 - 10:30 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:25 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:38 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:51 EDT
Monitoring
AWS support team continue to work towards full recovery of their services. At this time no Teletracking customers are affected. We'll continue to monitor this outage from the AWS status page. Service health - Oct 20, 2025 | AWS Health Dashboard | Global
Posted Oct 20, 2025 - 07:33 EDT
Investigating
The AWS support team is currently working on recovery and will be providing updates every 30 minutes.