Currently, there is an issue CMS slowness in the AWS page.

Incident Report for TeleTracking US

Resolved

This incident has been resolved.
Posted May 14, 2025 - 15:13 EDT

Update

We are continuing to monitor for any further issues.
Posted May 14, 2025 - 13:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 13:53 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 13:02 EDT

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 12:35 EDT
This incident affected: Overall US Platform.